Mediterranean Sea - The Norse Connection

  • I am stuck in the Mediterranean Sea Part IV because I cant open the door to get Thor's gauntlet. I am trying to throw the rocks out of the room on the right so I can use them to weigh down the floor pads. But I can't figure out how to get Lara to throw. When I push "E" (interact button) while she is holding the rock she swings the rock around but doesn't let go. Anyone figure this out? I have tried every button I could including the "K" button which is the button I thought was for throwing. Still no luck.



  • According to the booklet that came with the game the button to push to make Lara throw anything (grenade, rock or whatever) is the "K" button. When she is holding the rock and I push "K" nothing happens at all. Is there something I need to do to activate that button? Is there perhaps some kind of treasure I was supposed to find to activate it or something? Also in the onscreen menu there is no mention of a throw button so I cant figure out if I am doing something wrong, if this is a glitch in the game I got, or what. Any more thoughts?

    Thank you for your help.


  • Now I had to look this one up in the manual, as I used a gamepad to play the game: in my booklet it says that the correct button is Caps Lock, maybe you like to try that one. Otherwise I have no idea. For me the same button that works for grenades worked for throwing rocks too. I did nothing else to trigger it or such. I picked up a rock, using Interaction (E) and then look the way I want to throw and press "Throw Grenade".

    Have you looked through the button setup in the configuration? Maybe there is a conflict with more than one action being assigned to the K button, if that is indeed correct. (I might have another version, as I bought mine in Germany.)

  • Thanks for trying. I am wondering if I have a bad version of the game or something. I bought my game in the U.S. and in the manual it says that if I push "cntrl" it is to drop the item I am holding which is exactly what happens. So I still cant figure out how to throw. Very frustrating.